kz1300 banner

Welcome, Guest
Username: Password: Remember me

TOPIC: ZG1300 running much to lean

ZG1300 running much to lean 2 weeks 4 days ago #24543

  • Phil
  • Phil's Avatar
  • Offline
  • Platinum Sixer
  • Platinum Sixer
  • 1984 ZG1300-A1 DFI
  • Posts: 323
  • Thank you received: 80
Hi Gavin, those pressures sound a bit low; you should be getting about 33 psi at tickover rising to about 36 when the throttle is opened momentarily. How old is the fuel filter? Next step would be to replace the fuel pressure regulator valve, then the fuel pump.
Only dead fish go with the flow
The following user(s) said Thank You: Gavin

Please Log in or Create an account to join the conversation.

ZG1300 running much to lean 2 weeks 4 days ago #24544

  • Gavin
  • Gavin's Avatar Topic Author
  • Offline
  • Senior Sixer
  • Senior Sixer
  • Posts: 71
  • Thank you received: 14

Phil wrote: Hi Gavin, those pressures sound a bit low; you should be getting about 33 psi at tickover rising to about 36 when the throttle is opened momentarily. How old is the fuel filter? Next step would be to replace the fuel pressure regulator valve, then the fuel pump.

Hi Phil
The filter is 2 months old , I have borrowe a fuel pump although it’s performance is unknown, first I will try that , thanks for the pointer of the regulator before the pump though, I thought that if the regulator was iffy it would cause the bike to run over rich

Please Log in or Create an account to join the conversation.

ZG1300 running much to lean 2 weeks 20 hours ago #24592

  • Gavin
  • Gavin's Avatar Topic Author
  • Offline
  • Senior Sixer
  • Senior Sixer
  • Posts: 71
  • Thank you received: 14
I another bang your head against the wall session today,, I decided to check the vacuum hose to the regulator and redo the connection as the pipe ends appeared to be a bit flared out tbh the top one came off easily, anyway I did another pressure test with the same results as a previous post, I then decided I may as well try the pump I borrowed, so re soldered the dodgy connectors on the pump fitted it to the bike and nothing the relay is clicking and when 12v is applied to the pump it you can feel it power but will not turn ( it was a spare that came with a mates ZG.
So I have been looking for suitable fuel pumps in the UK and there are plenty of 3 bar /43.5 psi ones about, would one of these be ok or does it have to be 2.5 bar / 36psi
Forgot to add, the fast idle has stopped working as well

Cheers

Please Log in or Create an account to join the conversation.

Last edit: by Gavin.

ZG1300 running much to lean 2 weeks 16 hours ago #24599

  • Phil
  • Phil's Avatar
  • Offline
  • Platinum Sixer
  • Platinum Sixer
  • 1984 ZG1300-A1 DFI
  • Posts: 323
  • Thank you received: 80
Hi Gavin, I fitted an adjustable fuel pressure regulator to my ZG some years ago, but there's a guy on the European Z1300 Facebook page that's fitted a Herko PR4055 fuel pressure regulator that's pre-set to 45 psi & he says it works fine, I've set my adjustable regulator to about the same pressure & it runs better. Can be found on Ebay & is pretty reasonable at about 15 quid. As far as fuel pumps go I fitted a Pierburg automotive fuel injection pump some time ago too, wasn't cheap, but there is a cheaper alternative, search for "Holden Commodore VL Main EFI External Fuel Pump RB20E RB30ET 070" on Ebay, that will do the same job.
Only dead fish go with the flow
The following user(s) said Thank You: Gavin

Please Log in or Create an account to join the conversation.

ZG1300 running much to lean 2 weeks 16 hours ago #24602

  • Gavin
  • Gavin's Avatar Topic Author
  • Offline
  • Senior Sixer
  • Senior Sixer
  • Posts: 71
  • Thank you received: 14

Phil wrote: Hi Gavin, I fitted an adjustable fuel pressure regulator to my ZG some years ago, but there's a guy on the European Z1300 Facebook page that's fitted a Herko PR4055 fuel pressure regulator that's pre-set to 45 psi & he says it works fine, I've set my adjustable regulator to about the same pressure & it runs better. Can be found on Ebay & is pretty reasonable at about 15 quid. As far as fuel pumps go I fitted a Pierburg automotive fuel injection pump some time ago too, wasn't cheap, but there is a cheaper alternative, search for "Holden Commodore VL Main EFI External Fuel Pump RB20E RB30ET 070" on Ebay, that will do the same job.

From your reply I take it that a 3bar fuel pump will be ok even with a stock regulator

Please Log in or Create an account to join the conversation.

ZG1300 running much to lean 2 weeks 15 hours ago #24603

  • Phil
  • Phil's Avatar
  • Offline
  • Platinum Sixer
  • Platinum Sixer
  • 1984 ZG1300-A1 DFI
  • Posts: 323
  • Thank you received: 80
Should be, the stock fuel pump delivers more than 3 bar anyway :)
Only dead fish go with the flow

Please Log in or Create an account to join the conversation.

Time to create page: 0.072 seconds
Powered by Kunena Forum