kz1300 banner

Welcome, Guest
Username: Password: Remember me

TOPIC: ZG1300 running much to lean

ZG1300 running much to lean 11 months 6 days ago #24985

  • Gavin
  • Gavin's Avatar Topic Author
  • Offline
  • Senior Sixer
  • Senior Sixer
  • Posts: 74
  • Thank you received: 15
Phil
the answer to your question is no, I have looked at the balancing screws and cannot see how to get to the one for cylinders 5 and 6

Please Log in or Create an account to join the conversation.

ZG1300 running much to lean 3 weeks 17 hours ago #27455

  • ukblade
  • ukblade's Avatar
  • Offline
  • New Sixer
  • New Sixer
  • Posts: 18
  • Thank you received: 2

Phil wrote:

Kawboy wrote:

Phil wrote: Hi Gavin, I fitted an adjustable fuel pressure regulator to my ZG some years ago, but there's a guy on the European Z1300 Facebook page that's fitted a Herko PR4055 fuel pressure regulator that's pre-set to 45 psi & he says it works fine, I've set my adjustable regulator to about the same pressure & it runs better. Can be found on Ebay & is pretty reasonable at about 15 quid. As far as fuel pumps go I fitted a Pierburg automotive fuel injection pump some time ago too, wasn't cheap, but there is a cheaper alternative, search for "Holden Commodore VL Main EFI External Fuel Pump RB20E RB30ET 070" on Ebay, that will do the same job.

I'm a little concerned with the Holden pump. It's rated to feed a 5.0 L V8 engine which is almost 2-1/2 times more fuel than the ZG would need.
I found a fuel pump on EBay for Kawasaki Vulcan 1500 that I think would be more in line with the fuel needs of the ZG. See
EBAY inline fuel pump

The fuel pressure regulator maintains rail pressure regardless of what is supplied form the pump, excess is put back into the fuel tank via the fuel return line. The Pierburg pump I fitted to my ZG was originally intended for a Volvo 3.0 V6 & has been fine. Looking at that VN1500 pump you'd have to do a bit of extra plumbing to make it work as both pipe connection stubs are on the same side.


Bought an equivalent of the Holden pump you recommended Phil, this was a Bosch 0580464070, same size to within a few mm, just no 90^ elbow on the outlet.
Bike started almost straight away after I think 12 years sitting (I had turned the engine over prior to trying, just in case) .
Haven't pressure tested it as was running from a remote tank but for £45 I think it's a bargain.
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.097 seconds
Powered by Kunena Forum