Welcome, Guest
Username: Password: Remember me
Electrical
  • Page:
  • 1
  • 2

TOPIC:

DFI kill switch is turning my oil light on ? 3 weeks 5 days ago #32189

  • hoganter
  • hoganter's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 6
  • Thank you received: 1
Hi All
Have a DFI 1985 black with gold trim in australia.
Bike has an oil level and pressure circuit which I have isolated.
When I turn the kill switch on it earths out the oil light circuit and turns the oil light on.
Everything working ok except DFI light is flashing and sounds like I have dropped two pots.
Problem started when the oil warning  light holder shorted out due to corrosion but replaced with new.
Is there a wiring diagram for the DFI here as looks to be some variation between the models.
Also the oil level circuit does not connect to the warning light until I turn the kill switch on, but the oil pressure circuit does.
Meanwhile everyone is out riding and Im in the shed.
Any assistance appreciated
Thanks in Advance

 

Please Log in or Create an account to join the conversation.

DFI kill switch is turning my oil light on ? 3 weeks 1 day ago #32214

  • hoganter
  • hoganter's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 6
  • Thank you received: 1
Looks like it may be a poor earth wire ,

Please Log in or Create an account to join the conversation.

DFI kill switch is turning my oil light on ? 3 weeks 1 day ago #32215

  • Kawboy
  • Kawboy's Avatar
  • Offline
  • Sustaining Member
  • Sustaining Member
  • Posts: 2977
  • Thank you received: 1021
First -  Welcome to the site.

After you login to the site, you can open up the Service Manuals tab  and download the service manual for your bike. All of the wiring diagrams are in the manuals near the end of the manual. The wiring diagrams specifically for the DFI are in the DFI section of the manual.
The following user(s) said Thank You: hoganter

Please Log in or Create an account to join the conversation.

DFI kill switch is turning my oil light on ? 2 weeks 5 days ago #32231

  • hoganter
  • hoganter's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 6
  • Thank you received: 1
Found it
In the rear light section.
Bike was wired like this when I bought it, with a blown oil light bulb.
Too embarrassed to say how long it took me to find it, as I unplugged everything on the machine trying to isolate it.
Also removed the earth connections and battery and was still connected to the block!
Looked up the diagrams and saw an earth near the tail light so took the top box and tail cover off.
Classic electrical emotional rollercoaster, however now I can get to sleep easier without wiring diagrams in my head.
Now I will have a break and then start closing it up.
Will post some photos
Attachments:

Please Log in or Create an account to join the conversation.

DFI kill switch is turning my oil light on ? 2 weeks 4 days ago #32232

  • biltonjim
  • biltonjim's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 908
  • Thank you received: 236
Good to hear that you’ve fixed it.   What’s your story regarding involvement with the Kawasaki 1300?  How long have you owned this bike? What is your opinion on the bike?   What is the red bike in the background of your photo?

Please Log in or Create an account to join the conversation.

DFI kill switch is turning my oil light on ? 2 weeks 4 days ago #32233

  • hoganter
  • hoganter's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 6
  • Thank you received: 1
Had the z about 12 months I think.
Was looking for a CBX and then saw this one and bought it unseen from Queensland.
Had issues with a rusty tank as it was on the coast. Also discovered the fuel return to the tank was blocked which might explain why it was such a pig on fuel.
It is fun to ride however 1st gear is a bit tall for around town. looks and sounds great. Have not seen another one on the road yet.
Keen to get it back on the road running properly as it just "eats miles" so great for touring.
Have ordered a new set of pipes for it from the UK as the original ones are very thin.
Put a set of new ikon shocks on the rear which helped a lot.
The red bike is a BMW R1100GS which I rode for years, great bike but out of rego. Also KTM 450 6day with 20 hours on it and a legendary KX80.
The following user(s) said Thank You: biltonjim

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.388 seconds
Powered by Kunena Forum