kz1300 banner

Welcome, Guest
Username: Password: Remember me
Electrical
  • Page:
  • 1
  • 2

TOPIC:

Turn Signal Switch Issue 2 months 3 weeks ago #27476

  • Bucko
  • Bucko's Avatar Topic Author
  • Offline
  • Platinum Sixer
  • Platinum Sixer
  • Posts: 547
  • Thank you received: 128
I've noticed on the last couple of rides that the self cancelling turn signal switch on my 86 ZN1300 doesn't always self-cancel on the left side. I would say about 10% of the time, the left blinker will stay on while the right side self cancels 100% of the time. I remember having to take apart my 79 KZ1300 turn signal switch a few times to clean it out and make it operate smoothly - it would get quite 'sticky' - while the switch on my 86 works smoothly enough, just doesn't always cancel properly. Anyone else experience this behavior?
Hello from Canada's We(s)t coast.

Please Log in or Create an account to join the conversation.

Turn Signal Switch Issue 2 months 3 weeks ago #27478

  • strate6
  • strate6's Avatar
  • Offline
  • Platinum Sixer
  • Platinum Sixer
  • On An Adventure Before Dementia ! !
  • Posts: 1092
  • Thank you received: 331
Its probably that location screw on the bottom of the switch unit that isnt mentioned anywhere in the manual, thats not doing its job not "earthing" properly !!......

Pete F
UK
Why Have Four When You Can Have Six ?

Please Log in or Create an account to join the conversation.

Turn Signal Switch Issue 2 months 3 weeks ago #27480

  • scotch
  • scotch's Avatar
  • Offline
  • Sustaining Member
  • Sustaining Member
  • Posts: 1529
  • Thank you received: 636
Its probably that location screw on the bottom of the switch unit that isnt mentioned anywhere in the manual, thats not doing its job not "earthing" properly !!......
Pete F
UK

That would be logical place to start, Pete, given the recent topic. However, If that was the case then both signals would have the issue.
My thoughts are leaning towards something identical to the following:
www.kz1300.com/index.php/forum/electrica...cancel-module-repair
1980 KZ 1300 sr# KZT30A-009997
Always High - Know Fear !

Please Log in or Create an account to join the conversation.

Turn Signal Switch Issue 2 months 3 weeks ago #27481

  • Kawboy
  • Kawboy's Avatar
  • Offline
  • Sustaining Member
  • Sustaining Member
  • Posts: 2324
  • Thank you received: 682
Let's not forget that the cancellation board needs to see 4 or 5 flashes of the light circuit + a 50 count of the speedo counter to cancel the signal SO, in its logic, if it doesn't SEE the resistance of the circuit, it won't initiate a cancellation phase. That being said, bad connections to the feed or ground in that circuit could also be an issue. Check the grounds at the signal lights and the wire terrminals on the ground and feed wiring as well. If I were troubleshooting this, I would start at the grounds for the signal lights themselves due to the exposure of them to the environment.
I can appreciate the supplied resource topic discussing the cancellation board and bad soldering as it's valuable info. I learned a hard lesson trying to troubleshoot a failed heated driver's seat in an Audi 5000 turbo quattro. The circuit involved 5 relays, 3 circuits and God knows how many switches. After 4 days of testing, I finally decided to resistance test the heating element in the seat ans sure enough it had an open circuit. In hindsight, I should have taken a moment and thought through just what most likely could break. Sitting in the seat, getting in and out of the seat, bouncing in the seat- why didn't i think it was the most likely failure.
Bottomline- Electrical troubles- grounds and connections, grounds and connections before anything else. The electrics on these bikes are subject to the weather you ride in. If they built these bikes with amp seal weather tite connectors then it might be a slightly different story. Bullet connectors are far from weather tite.

Please Log in or Create an account to join the conversation.

Turn Signal Switch Issue 3 weeks 23 hours ago #27961

  • Bucko
  • Bucko's Avatar Topic Author
  • Offline
  • Platinum Sixer
  • Platinum Sixer
  • Posts: 547
  • Thank you received: 128
Update on this....

As part my recent investigation into why the headlight voltage was so low. I partially disassembled the left hand switch cluster to clean the headlight switch contacts. I also put a few sparing drops of silicon lubricant on the rail that the signal light switch slides on and now my switch is quite a bit easier to move and no longer misses a 'shut off'. I also reset the screw thing so that may have had a play in it as well.
Hello from Canada's We(s)t coast.

Please Log in or Create an account to join the conversation.

Turn Signal Switch Issue 3 weeks 18 hours ago #27962

  • scotch
  • scotch's Avatar
  • Offline
  • Sustaining Member
  • Sustaining Member
  • Posts: 1529
  • Thank you received: 636
I also reset the screw thing so that may have had a play in it as well.

This was, not that long ago, a contentious topic.
From the factory the powder coating (or very thick/hard paint) was applied to the entire body, including the clamping surfaces. No continuity !
That " screw thing" pierced this non conductive coating to provide a ground for the signal solenoid. By now, that coating on most switch assemblies has likely been worn off enough to allow for continuity. I'd recommend utilizing the grounding screw to maintain the best conductivity.
1980 KZ 1300 sr# KZT30A-009997
Always High - Know Fear !

Please Log in or Create an account to join the conversation.

Last edit: by scotch.
  • Page:
  • 1
  • 2
Time to create page: 0.089 seconds
Powered by Kunena Forum