Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC:

ZN1300 Rad Hose 1 year 2 days ago #31278

  • zed_thirteen
  • zed_thirteen's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 530
  • Thank you received: 138

I got mine from autosiliconehoses.com (£7.86 + £3.25 shipping):Silicone Polyester Reinforced Hose - 32mm - 45 Degree Elbows - 15 ColoursSKU: P SSE 045 032 KColourBlack
I'm still following up in this.  I think I've found a suitable hose, but I've read some stuff on silicone hoses needing special clamps.  Did you reuse the OEM clamps?
I purchased stainless jubilee/worm type hose clamps. I've had the radiator off a couple of times and the bottom one did start leaking so I had to replace it - so perhaps there is a problem?
1980 KZ1300 B2 Touring/A2
1990 ZZ-R1100 C1
The following user(s) said Thank You: Bucko

Please Log in or Create an account to join the conversation.

Waterpump mechanical seal. 11 months 1 week ago #31307

  • Bucko
  • Bucko's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 672
  • Thank you received: 164
I installed a new hose, but only the bottom one as the inside of the hose was a bit ratty from the curd that had built up on the lower rad spigot.  The top hose was in excelling shape so I reused it.  Also reused all hose clamps, which were all in like-new condition.
 
Hello from Canada's We(s)t coast.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.096 seconds
Powered by Kunena Forum