kz1300 banner

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Clutch Lever Dust Boot ??

Clutch Lever Dust Boot ?? 1 week 12 hours ago #24629

  • Bucko
  • Bucko's Avatar Topic Author
  • Offline
  • Platinum Sixer
  • Platinum Sixer
  • Posts: 397
  • Thank you received: 86
The Clutch cable on my ZN1300to requires frequent attention. It can be difficult to pull ever after lubrication because of the way the bottom end of the cable bends to enter the case, and because the cable leaves a bit of a hanging loop where water collects (inside the cable) and corrodes the inner cable/inner cable jacket. Not sure how water is getting in there but probably from me washing the bike although I'm generally careful to avoid spaying water near the upper end of the cable. Just wondering if anyone else has experienced this and if anyone knows of a generic rubber boot that will fit over the upper end of the cable like my Honda's have:
Hello from Canada's We(s)t coast.

Please Log in or Create an account to join the conversation.

Last edit: by Bucko.

Clutch Lever Dust Boot ?? 1 week 11 hours ago #24631

  • Frank833
  • Frank833's Avatar
  • Offline
  • Golden Sixer
  • Golden Sixer
  • Posts: 260
  • Thank you received: 83
Hydraulic conversion fixes all...

Please Log in or Create an account to join the conversation.

Clutch Lever Dust Boot ?? 1 week 3 hours ago #24632

  • Bucko
  • Bucko's Avatar Topic Author
  • Offline
  • Platinum Sixer
  • Platinum Sixer
  • Posts: 397
  • Thank you received: 86

Frank833 wrote: Hydraulic conversion fixes all...


Would truly love to go that route but for me there are a couple of problems:

Biggest problem: I'm pretty sure the factory Voyager crash guards are too close - that is - there's no room to mount the slave adapter (the cable barely fits properly).

Second problem: my Voyager has a collector plate so it needs to be 'original'. If I could find a clutch reservoir off a similar vintage model that looked the same as the brake reservoir, I might get away with it - but I don't think any mid 80's Kawi models came with hydraulic clutches. I have this exact same issue with a couple of old Hondas.
Hello from Canada's We(s)t coast.

Please Log in or Create an account to join the conversation.

Last edit: by Bucko.
  • Page:
  • 1
Time to create page: 0.067 seconds
Powered by Kunena Forum